Update to 4.8.13

This commit is contained in:
Salvatore Bonaccorso 2016-12-10 13:08:23 +01:00
parent 93304bd632
commit 03b836246e
2 changed files with 39 additions and 3 deletions

38
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.8.12-1) UNRELEASED; urgency=medium
linux (4.8.13-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.12
@ -35,6 +35,42 @@ linux (4.8.12-1) UNRELEASED; urgency=medium
- mm, oom: stop pre-mature high-order OOM killer invocations
- flow_dissect: call init_default_flow_dissectors() earlier
- scsi: mpt3sas: Unblock device after controller reset
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.8.13
- libata-scsi: Fixup ata_gen_passthru_sense()
- scsi: hpsa: use bus '3' for legacy HBA devices
- scsi: libfc: fix seconds_since_last_reset miscalculation
- mm, thp: propagation of conditional compilation in khugepaged.c
- thp: fix corner case of munlock() of PTE-mapped THPs
- zram: fix unbalanced idr management at hot removal
- mm: fix false-positive WARN_ON() in truncate/invalidate for hugetlb
- ovl: fix d_real() for stacked fs
- Input: change KEY_DATA from 0x275 to 0x277
- Input: psmouse - disable automatic probing of BYD touchpads
- rcu: Fix soft lockup for rcu_nocb_kthread
- mm: workingset: fix NULL ptr in count_shadow_nodes
- PCI: Export pcie_find_root_port
- PCI: Set Read Completion Boundary to 128 iff Root Port supports it
(_HPX)
- mwifiex: printk() overflow with 32-byte SSIDs
- [arm64] KVM: vgic: Don't notify EOI for non-SPIs
- [x86] drm/i915: Don't touch NULL sg on i915_gem_object_get_pages_gtt()
error
- [x86] drm/i915: drop the struct_mutex when wedged or trying to reset
- [x86] drm/amdgpu: fix power state when port pm is unavailable
- drm/radeon: fix power state when port pm is unavailable
- [x86] drm/amdgpu: fix check for port PM availability
- drm/radeon: fix check for port PM availability
- [arm64] dts: juno: fix cluster sleep state entry latency on all SoC
versions
- KVM: use after free in kvm_ioctl_create_device()
- pwm: Fix device reference leak
- [x86] perf: Restore TASK_SIZE check on frame pointer
- [armhf] clk: sunxi: Fix M factor computation for APB1
- batman-adv: Detect missing primaryif during tp_send as error
- [arm64] cpufeature: Schedule enable() calls instead of calling them via
IPI
- [arm64] mm: Set PSTATE.PAN from the cpu_enable_pan() call
- [arm64] suspend: Reconfigure PSTATE after resume from idle
[ Uwe Kleine-König ]
* [armhf] dts: armada-385: add support for Turris Omnia

View File

@ -85,7 +85,7 @@ Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
spin_unlock_irq(&mapping->tree_lock);
--- a/mm/workingset.c
+++ b/mm/workingset.c
@@ -334,7 +334,8 @@ void workingset_activation(struct page *
@@ -334,7 +334,8 @@ out:
* point where they would still be useful.
*/
@ -106,7 +106,7 @@ Signed-off-by: Sebastian Andrzej Siewior <bigeasy@linutronix.de>
+ shadow_nodes = list_lru_shrink_count(&__workingset_shadow_nodes, sc);
+ local_unlock_irq(workingset_shadow_lock);
if (memcg_kmem_enabled()) {
if (sc->memcg) {
pages = mem_cgroup_node_nr_lru_pages(sc->memcg, sc->nid,
@@ -438,9 +439,9 @@ static enum lru_status shadow_lru_isolat
spin_unlock(&mapping->tree_lock);