asix: Add support for Lenovo 10/100 USB dongle

svn path=/dists/sid/linux/; revision=19607
This commit is contained in:
Ben Hutchings 2012-12-16 12:48:56 +00:00
parent 7e597b69c2
commit 037953707b
3 changed files with 31 additions and 0 deletions

1
debian/changelog vendored
View File

@ -4,6 +4,7 @@ linux (3.2.35-2) UNRELEASED; urgency=low
* [rt] Update to 3.2.35-rt52
* audit: Increase maximum number of names logged per syscall to 30
(Closes: #631799)
* asix: Add support for Lenovo 10/100 USB dongle
-- Ben Hutchings <ben@decadent.org.uk> Mon, 10 Dec 2012 13:13:53 +0000

View File

@ -0,0 +1,29 @@
From: Quinlan Pfiffer <qpfiffer@gmail.com>
Date: Fri, 28 Sep 2012 19:58:44 +0000
Subject: asix: Adds support for Lenovo 10/100 USB dongle.
commit 66dc81ecd71332783c92fb170950d5ddb43da461 upstream.
This dongle ships with the X1 Carbon, and has an AX88772B
usb to ethernet chip in it.
Signed-off-by: Quinlan Pfiffer <qpfiffer@gmail.com>
Signed-off-by: David S. Miller <davem@davemloft.net>
[bwh: Backported to 3.2: adjust filename]
---
drivers/net/usb/asix.c | 4 ++++
1 file changed, 4 insertions(+)
--- a/drivers/net/usb/asix.c
+++ b/drivers/net/usb/asix.c
@@ -1616,6 +1616,10 @@ static const struct usb_device_id produc
USB_DEVICE (0x04f1, 0x3008),
.driver_info = (unsigned long) &ax8817x_info,
}, {
+ // Lenovo U2L100P 10/100
+ USB_DEVICE (0x17ef, 0x7203),
+ .driver_info = (unsigned long) &ax88772_info,
+}, {
// ASIX AX88772B 10/100
USB_DEVICE (0x0b95, 0x772b),
.driver_info = (unsigned long) &ax88772_info,

View File

@ -432,3 +432,4 @@ bugfix/all/exec-do-not-leave-bprm-interp-on-stack.patch
bugfix/all/exec-use-ELOOP-for-max-recursion-depth.patch
bugfix/all/megaraid_sas-fix-memory-leak-if-SGL-has-zero-length-entries.patch
debian/audit-increase-AUDIT_NAMES.patch
features/all/asix-Adds-support-for-Lenovo-10-100-USB-dongle.patch