Added powerpc-mv643xx-hotplug-support.patch patch to add support for hotplug

for the mv643xx_eth ethernet driver.

svn path=/dists/sid/linux-2.6/; revision=4219
This commit is contained in:
Sven Luther 2005-09-15 12:16:46 +00:00
parent 928767db0f
commit 034f2b56bb
3 changed files with 42 additions and 1 deletions

7
debian/changelog vendored
View File

@ -9,7 +9,12 @@ linux-2.6 (2.6.12-7) UNRELEASED; urgency=low
and SMP builds. This fixes a bug detected on ia64 whose symptom was
unloadable modules in UP builds. (closes: #325070)
-- dann frazier <dannf@debian.org> Tue, 13 Sep 2005 18:02:36 -0600
[ Sven Luther ]
* [powerpc] Added hotplug support to the mv643xx_eth driver :
powerpc-mv643xx-hotplug-support.patch
thanks go to Nicolas Det for providing the patch.
-- Sven Luther <luther@debian.org> Thu, 15 Sep 2005 14:16:19 +0200
linux-2.6 (2.6.12-6) unstable; urgency=high

View File

@ -0,0 +1,35 @@
#
# Hotplug support patch for mv643xx_eth driver used on pegasos machines.
# Author: Nicolas Det <nicolas.det@bplan-gmbh.de>
# Upstream status: In the process of being submitted, may need a bit of
# cleanup in order to not break embedded arches using this controller, but
# should not be a worry for debian.
#
--- linux-2.6.14-rc1/drivers/net/mv643xx_eth.c 2005-09-14 08:15:11.000065096 +0200
+++ linux-2.6.14-rc1_nico/drivers/net/mv643xx_eth.c 2005-09-15 12:57:50.646269250 +0200
@@ -1533,6 +1533,9 @@
printk(KERN_NOTICE "%s: RX NAPI Enabled \n", dev->name);
#endif
+ if (mp->tx_sram_size > 0)
+ printk(KERN_NOTICE "%s: Using SRAM\n", dev->name);
+
return 0;
out:
@@ -1640,6 +1643,15 @@
" and Dale Farnsworth");
MODULE_DESCRIPTION("Ethernet driver for Marvell MV643XX");
+#include <linux/pci.h>
+
+static struct pci_device_id pci_marvell_mv64360[] = {
+ { PCI_DEVICE(PCI_VENDOR_ID_MARVELL, PCI_DEVICE_ID_MARVELL_MV64360) },
+ { }
+ };
+
+MODULE_DEVICE_TABLE(pci, pci_marvell_mv64360);
+
/*
* The second part is the low level driver of the gigE ethernet ports.
*/

1
debian/patches-debian/series/2.6.12-7 vendored Normal file
View File

@ -0,0 +1 @@
+ powerpc-mv643xx-hotplug-support.patch