Use the new i2c framework to load rtc-rs5c372 for the GLAN Tank.

svn path=/dists/sid/linux-2.6/; revision=9914
This commit is contained in:
Gordon Farquharson 2007-12-07 05:30:33 +00:00
parent 1b5286fd9d
commit 033a9fc815
3 changed files with 50 additions and 1 deletions

7
debian/changelog vendored
View File

@ -1,8 +1,13 @@
linux-2.6 (2.6.23-2) UNRELEASED; urgency=low
[ dann frazier ]
* [ia64]: Enable BLK_CPQ_DA
-- dann frazier <dannf@debian.org> Tue, 04 Dec 2007 13:17:13 -0700
[ Gordon Farquharson ]
* [arm/iop32x] Use the new i2c framework to load rtc-rs5c372 for the
GLAN Tank.
-- Gordon Farquharson <gordonfarquharson@gmail.com> Thu, 6 Dec 2007 22:27:14 -0700
linux-2.6 (2.6.23-1) unstable; urgency=low

View File

@ -0,0 +1,43 @@
--- a/arch/arm/mach-iop32x/glantank.c
+++ b/arch/arm/mach-iop32x/glantank.c
@@ -3,7 +3,7 @@
*
* Board support code for the GLAN Tank.
*
- * Copyright (C) 2006 Martin Michlmayr <tbm@cyrius.com>
+ * Copyright (C) 2006, 2007 Martin Michlmayr <tbm@cyrius.com>
* Copyright (C) 2006 Lennert Buytenhek <buytenh@wantstofly.org>
*
* This program is free software; you can redistribute it and/or modify it
@@ -21,6 +21,7 @@
#include <linux/serial_core.h>
#include <linux/serial_8250.h>
#include <linux/mtd/physmap.h>
+#include <linux/i2c.h>
#include <linux/platform_device.h>
#include <asm/hardware.h>
#include <asm/io.h>
@@ -166,6 +167,13 @@ static struct platform_device glantank_serial_device = {
.resource = &glantank_uart_resource,
};
+static struct i2c_board_info __initdata glantank_i2c_devices[] = {
+ {
+ I2C_BOARD_INFO("rtc-rs5c372", 0x32),
+ .type = "rs5c372a",
+ },
+};
+
static void glantank_power_off(void)
{
__raw_writeb(0x01, 0xfe8d0004);
@@ -183,6 +191,9 @@ static void __init glantank_init_machine(void)
platform_device_register(&iop3xx_dma_0_channel);
platform_device_register(&iop3xx_dma_1_channel);
+ i2c_register_board_info(0, glantank_i2c_devices,
+ ARRAY_SIZE(glantank_i2c_devices));
+
pm_power_off = glantank_power_off;
}

1
debian/patches/series/2 vendored Normal file
View File

@ -0,0 +1 @@
+ bugfix/arm/glantank-rtc.patch