Register the F75375 device in the GLAN Tank platform code (L-A-K patch

number 4865/1).

svn path=/dists/trunk/linux-2.6/; revision=10833
This commit is contained in:
Gordon Farquharson 2008-03-14 03:37:40 +00:00
parent ff23980619
commit 02dda38cc9
3 changed files with 39 additions and 0 deletions

1
debian/changelog vendored
View File

@ -55,6 +55,7 @@ linux-2.6 (2.6.25~rc5-1~experimental.1) UNRELEASED; urgency=low
* [arm/iop32x] Enable support for the GLAN Tank flash chip (M29W400DB).
* [arm/iop32x] Do not build the ARTOP PATA driver (PATA_ARTOP).
* [arm/iop32x] Enable CMDLINE_PARTS.
* [arm/iop32x] Register the F75375 device in the GLAN Tank platform code.
[ Aurelien Jarno ]
* [mips/mipsel] Enable CONFIG_NO_HZ, CONFIG_HIGH_RES_TIMERS for dynticks

View File

@ -0,0 +1,37 @@
diff --git a/arch/arm/mach-iop32x/glantank.c b/arch/arm/mach-iop32x/glantank.c
index 74c65ce..d2a7b04 100644
--- a/arch/arm/mach-iop32x/glantank.c
+++ b/arch/arm/mach-iop32x/glantank.c
@@ -14,8 +14,10 @@
#include <linux/mm.h>
#include <linux/init.h>
+#include <linux/f75375s.h>
#include <linux/kernel.h>
#include <linux/pci.h>
+#include <linux/pm.h>
#include <linux/string.h>
#include <linux/slab.h>
#include <linux/serial_core.h>
@@ -167,11 +169,21 @@ static struct platform_device glantank_serial_device = {
.resource = &glantank_uart_resource,
};
+static struct f75375s_platform_data glantank_f75375s = {
+ .pwm = { 255, 255 },
+ .pwm_enable = { 0, 0 },
+};
+
static struct i2c_board_info __initdata glantank_i2c_devices[] = {
{
I2C_BOARD_INFO("rtc-rs5c372", 0x32),
.type = "rs5c372a",
},
+ {
+ I2C_BOARD_INFO("f75375", 0x2e),
+ .type = "f75375",
+ .platform_data = &glantank_f75375s,
+ },
};
static void glantank_power_off(void)

View File

@ -36,3 +36,4 @@
+ bugfix/all/rtc-x1205-new-style-conversion.patch
+ bugfix/all/rtc-x1205-new-style-conversion-checkpatch-fixes.patch
+ bugfix/all/file2alias-cross-compile-fix.patch
+ features/arm/glantank-register-f75375s.patch