Update to 4.19.91

* Drop/refresh patches as appropriate
* Several ABI changes still need to be resolved
This commit is contained in:
Ben Hutchings 2019-12-28 01:06:50 +00:00
parent a13b44e33a
commit 02a0b3eb56
4 changed files with 408 additions and 88 deletions

390
debian/changelog vendored
View File

@ -1,4 +1,4 @@
linux (4.19.88-1) UNRELEASED; urgency=medium
linux (4.19.91-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.88
@ -254,6 +254,394 @@ linux (4.19.88-1) UNRELEASED; urgency=medium
- HID: core: check whether Usage Page item is after Usage ID items
- [x86] platform: hp-wmi: Fix ACPI errors caused by too small buffer
- [x86] platform: hp-wmi: Fix ACPI errors caused by passing 0 as input size
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.89
- rsi: release skb if rsi_prepare_beacon fails (CVE-2019-19071)
- [arm64] tegra: Fix 'active-low' warning for Jetson TX1 regulator
- usb: gadget: u_serial: add missing port entry locking
- [arm64] tty: serial: msm_serial: Fix flow control
- [armhf,arm64] serial: pl011: Fix DMA ->flush_buffer()
- serial: serial_core: Perform NULL checks for break_ctl ops
- autofs: fix a leak in autofs_expire_indirect()
- [arm64] RDMA/hns: Correct the value of HNS_ROCE_HEM_CHUNK_LEN
- iwlwifi: pcie: don't consider IV len in A-MSDU
- exportfs_decode_fh(): negative pinned may become positive without the
parent locked
- audit_get_nd(): don't unlock parent too early
- xfrm: release device reference for invalid state
- sched/core: Avoid spurious lock dependencies
- perf/core: Consistently fail fork on allocation failures
- ALSA: pcm: Fix stream lock usage in snd_pcm_period_elapsed()
- [armhf,arm64] drm/sun4i: tcon: Set min division of TCON0_DCLK to 1.
- rsxx: add missed destroy_workqueue calls in remove
- i2c: core: fix use after free in of_i2c_notify
- serial: core: Allow processing sysrq at port unlock time
- cxgb4vf: fix memleak in mac_hlist initialization
- iwlwifi: mvm: synchronize TID queue removal
- iwlwifi: trans: Clear persistence bit when starting the FW
- iwlwifi: mvm: Send non offchannel traffic via AP sta
- [armhf] 8813/1: Make aligned 2-byte getuser()/putuser() atomic on ARMv6+
- audit: Embed key into chunk
- netfilter: nf_tables: don't use position attribute on rule replacement
- net/mlx5: Release resource on error flow
- [arm64] clk: sunxi-ng: a64: Fix gate bit of DSI DPHY
- ice: Fix NVM mask defines
- dlm: fix possible call to kfree() for non-initialized pointer
- [armhf] dts: exynos: Fix LDO13 min values on Odroid XU3/XU4/HC1
- [armhf,arm64] rtc: max77686: Fix the returned value in case of error in
'max77686_rtc_read_time()'
- i40e: don't restart nway if autoneg not supported
- virtchnl: Fix off by one error
- [armhf] clk: rockchip: fix rk3188 sclk_smc gate data
- [armhf] clk: rockchip: fix rk3188 sclk_mac_lbtest parameter ordering
- [armhf] dts: rockchip: Fix rk3288-rock2 vcc_flash name
- dlm: fix missing idr_destroy for recover_idr
- [armhf,arm64] net: dsa: mv88e6xxx: Work around mv886e6161 SERDES missing
MII_PHYSID2
- [s390x] scsi: zfcp: update kernel message for invalid FCP_CMND length,
it's not the CDB
- [s390x] scsi: zfcp: drop default switch case which might paper over
missing case
- [armhf] bus: ti-sysc: Fix getting optional clocks in clock_roles
- [armhf] dts: imx6: RDU2: fix eGalax touchscreen node
- crypto: ecc - check for invalid values in the key verification test
- crypto: bcm - fix normal/non key hash algorithm failure
- [arm64] dts: zynqmp: Fix node names which contain "_"
- [arm64] pinctrl: qcom: ssbi-gpio: fix gpio-hog related boot issues
- [arm*] firmware: raspberrypi: Fix firmware calls with large buffers
- mm/vmstat.c: fix NUMA statistics updates
- [arm64] clk: rockchip: fix I2S1 clock gate register for rk3328
- [arm64] clk: rockchip: fix ID of 8ch clock of I2S1 for rk3328
- sctp: count sk_wmem_alloc by skb truesize in sctp_packet_transmit
- regulator: Fix return value of _set_load() stub
- USB: serial: f81534: fix reading old/new IC config
- xfs: extent shifting doesn't fully invalidate page cache
- net-next/hinic:fix a bug in set mac address
- net-next/hinic: fix a bug in rx data flow
- ice: Fix return value from NAPI poll
- ice: Fix possible NULL pointer de-reference
- iomap: FUA is wrong for DIO O_DSYNC writes into unwritten extents
- iomap: sub-block dio needs to zeroout beyond EOF
- iomap: dio data corruption and spurious errors when pipes fill
- iomap: readpages doesn't zero page tail beyond EOF
- iw_cxgb4: only reconnect with MPAv1 if the peer aborts
- [mips*/octeon] octeon-platform: fix typing
- net/smc: use after free fix in smc_wr_tx_put_slot()
- [armhf] dts: exynos: Use Samsung SoC specific compatible for DWC2 module
- media: pulse8-cec: return 0 when invalidating the logical address
- media: cec: report Vendor ID after initialization
- iwlwifi: fix cfg structs for 22000 with different RF modules
- net/ipv6: re-do dad when interface has IFF_NOARP flag change
- [x86] dmaengine: dw-dmac: implement dma protection control setting
- [armhf,arm64] usb: dwc3: debugfs: Properly print/set link state for HS
- [armhf,arm64] usb: dwc3: don't log probe deferrals; but do log other
error codes
- ACPI: fix acpi_find_child_device() invocation in acpi_preset_companion()
- f2fs: fix to account preflush command for noflush_merge mode
- f2fs: fix count of seg_freed to make sec_freed correct
- f2fs: change segment to section in f2fs_ioc_gc_range
- [armhf] dts: rockchip: Fix the PMU interrupt number for rv1108
- [armhf] dts: rockchip: Assign the proper GPIO clocks for rv1108
- f2fs: fix to allow node segment for GC by ioctl path
- nvme: Free ctrl device name on init failure
- dma-mapping: fix return type of dma_set_max_seg_size()
- [armhf] serial: imx: fix error handling in console_setup
- [armhf] i2c: imx: don't print error message on probe defer
- [arm64] clk: meson: Fix GXL HDMI PLL fractional bits width
- [armhf,arm64] gpu: host1x: Fix syncpoint ID field size on Tegra186
- lockd: fix decoding of TEST results
- sctp: increase sk_wmem_alloc when head->truesize is increased
- [x86] iommu/amd: Fix line-break in error log reporting
- [armhf] dts: sun8i: a23/a33: Fix OPP DTC warnings
- [armhf] dts: sun8i: v3s: Change pinctrl nodes to avoid warning
- nfsd: fix a warning in __cld_pipe_upcall()
- bpf: btf: implement btf_name_valid_identifier()
- bpf: btf: check name validity for various types
- [armhf] OMAP1/2: fix SoC name printing
- [arm64] dts: meson-gxl-libretech-cc: fix GPIO lines names
- [arm64] dts: meson-gxbb-nanopi-k2: fix GPIO lines names
- [arm64] dts: meson-gxbb-odroidc2: fix GPIO lines names
- [arm64] dts: meson-gxl-khadas-vim: fix GPIO lines names
- net/x25: fix called/calling length calculation in x25_parse_address_block
- net/x25: fix null_x25_address handling
- tcp: make tcp_space() aware of socket backlog
- tcp: fix off-by-one bug on aborting window-probing socket
- tcp: fix SNMP under-estimation on failed retransmission
- tcp: fix SNMP TCP timeout under-estimation
- kbuild: fix single target build for external module
- mtd: fix mtd_oobavail() incoherent returned value
- [arm64] clk: meson: meson8b: fix the offset of vid_pll_dco's N value
- [armhf,arm64] clk: sunxi-ng: h3/h5: Fix CSI_MCLK parent
- [arm64] clk: qcom: Fix MSM8998 resets
- dlm: fix invalid cluster name warning
- net/mlx4_core: Fix return codes of unsupported operations
- pstore/ram: Avoid NULL deref in ftrace merging failure path
- [mips*/octeon] cvmx_pko_mem_debug8: use oldest forward compatible
definition
- nfsd: Return EPERM, not EACCES, in some SETATTR cases
- media: uvcvideo: Abstract streaming object lifetime
- [armhf] dts: sun8i: h3: Fix the system-control register range
- tty: Don't block on IO when ldisc change is pending
- media: stkwebcam: Bugfix for wrong return values
- sctp: frag_point sanity check
- IB/hfi1: Ignore LNI errors before DC8051 transitions to Polling state
- IB/hfi1: Close VNIC sdma_progress sleep window
- mlx4: Use snprintf instead of complicated strcpy
- [armhf] dts: sunxi: Fix PMU compatible strings
- [armhf] dts: am335x-pdu001: Fix polarity of card detection input
- net: aquantia: fix RSS table and key sizes
- sched/fair: Scale bandwidth quota and period without losing quota/period
ratio precision
- fuse: verify nlink
- fuse: verify attributes
- [x86] ALSA: hda/realtek - Enable internal speaker of ASUS UX431FLC
- [x86] ALSA: hda/realtek - Enable the headset-mic on a Xiaomi's laptop
- [x86] ALSA: hda/realtek - Dell headphone has noise on unmute for ALC236
- ALSA: pcm: oss: Avoid potential buffer overflows
- [x86] ALSA: hda - Add mute led support for HP ProBook 645 G4
- [x86] Input: synaptics - switch another X1 Carbon 6 to RMI/SMbus
- [x86] Input: synaptics-rmi4 - re-enable IRQs in f34v7_do_reflash
- [x86] Input: synaptics-rmi4 - don't increment rmiaddr for SMBus transfers
- [x86] Input: goodix - add upside-down quirk for Teclast X89 tablet
- Input: Fix memory leak in psxpad_spi_probe
- [i386] mm: Sync only to VMALLOC_END in vmalloc_sync_all()
- [x86] PCI: Avoid AMD FCH XHCI USB PME# from D0 defect
- xfrm interface: fix memory leak on creation
- xfrm interface: avoid corruption on changelink
- xfrm interface: fix list corruption for x-netns
- xfrm interface: fix management of phydev
- CIFS: Fix NULL-pointer dereference in smb2_push_mandatory_locks
- CIFS: Fix SMB2 oplock break processing
- tty: vt: keyboard: reject invalid keycodes
- can: slcan: Fix use-after-free Read in slcan_open
- kernfs: fix ino wrap-around detection
- jbd2: Fix possible overflow in jbd2_log_space_left()
- [arm64] drm/msm: fix memleak on release
- [i386] drm/i810: Prevent underflow in ioctl
- [armhf,arm64] KVM: vgic: Don't rely on the wrong pending table
- [x86] KVM: do not modify masked bits of shared MSRs
- [x86] KVM: fix presentation of TSX feature in ARCH_CAPABILITIES
- [x86] KVM: Grab KVM's srcu lock when setting nested state
- crypto: af_alg - cast ki_complete ternary op to int
- [x86] crypto: ccp - fix uninitialized list head
- crypto: ecdh - fix big endian bug in ECC library
- crypto: user - fix memory leak in crypto_report (CVE-2019-19062)
- mwifiex: update set_mac_address logic
- can: ucan: fix non-atomic allocation in completion handler
- RDMA/qib: Validate ->show()/store() callbacks before calling them
- iomap: Fix pipe page leakage during splicing
- thermal: Fix deadlock in thermal thermal_zone_device_check
- vcs: prevent write access to vcsu devices (CVE-2019-19252)
- binder: Fix race between mmap() and binder_alloc_print_pages()
- binder: Handle start==NULL in binder_update_page_range()
- ALSA: hda - Fix pending unsol events at shutdown
- perf script: Fix invalid LBR/binary mismatch error
- splice: don't read more than available pipe space
- iomap: partially revert 4721a601099 (simulated directio short read on
EFAULT)
- xfs: add missing error check in xfs_prepare_shift()
- ASoC: rsnd: fixup MIX kctrl registration
- [x86] KVM: fix out-of-bounds write in KVM_GET_EMULATED_CPUID
(CVE-2019-19332)
- net: qrtr: fix memort leak in qrtr_tun_write_iter (CVE-2019-19079)
- appletalk: Fix potential NULL pointer dereference in
unregister_snap_client (CVE-2019-19227)
- appletalk: Set error code if register_snap_client failed
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.90
- usb: gadget: configfs: Fix missing spin_lock_init()
- [x86] usb: gadget: pch_udc: fix use after free
- scsi: qla2xxx: Fix driver unload hang
- [arm64] media: venus: remove invalid compat_ioctl32 handler
- USB: uas: honor flag to avoid CAPACITY16
- USB: uas: heed CAPACITY_HEURISTICS
- usb: Allow USB device to be warm reset in suspended state
- staging: rtl8188eu: fix interface sanity check
- staging: rtl8712: fix interface sanity check
- staging: gigaset: fix general protection fault on probe
- staging: gigaset: fix illegal free on probe errors
- staging: gigaset: add endpoint-type sanity check
- usb: xhci: only set D3hot for pci device
- xhci: Fix memory leak in xhci_add_in_port()
- xhci: Increase STS_HALT timeout in xhci_suspend()
- xhci: handle some XHCI_TRUST_TX_LENGTH quirks cases as default behaviour.
- [armhf] dts: pandora-common: define wl1251 as child node of mmc3
- [x86] iio: imu: inv_mpu6050: fix temperature reporting using bad unit
- USB: atm: ueagle-atm: add missing endpoint check
- USB: idmouse: fix interface sanity checks
- USB: serial: io_edgeport: fix epic endpoint lookup
- usb: roles: fix a potential use after free
- USB: adutux: fix interface sanity check
- usb: core: urb: fix URB structure initialization function
- usb: mon: Fix a deadlock in usbmon between mmap and read
- tpm: add check after commands attribs tab allocation
- virtio-balloon: fix managed page counts when migrating pages between
zones
- [armhf,arm64] usb: dwc3: gadget: Fix logical condition
- [armhf,arm64] usb: dwc3: ep0: Clear started flag on completion
- btrfs: check page->mapping when loading free space cache
- btrfs: use refcount_inc_not_zero in kill_all_nodes
- Btrfs: fix metadata space leak on fixup worker failure to set range as
delalloc
- Btrfs: fix negative subv_writers counter and data space leak after
buffered write
- btrfs: Avoid getting stuck during cyclic writebacks
- btrfs: Remove btrfs_bio::flags member
- Btrfs: send, skip backreference walking for extents with many references
- btrfs: record all roots for rename exchange on a subvol
- rtlwifi: rtl8192de: Fix missing code to retrieve RX buffer address
- rtlwifi: rtl8192de: Fix missing callback that tests for hw release of
buffer
- rtlwifi: rtl8192de: Fix missing enable interrupt flag
- ovl: fix corner case of non-unique st_dev;st_ino
- ovl: relax WARN_ON() on rename to self
- [armhf] hwrng: omap - Fix RNG wait loop timeout
- dm writecache: handle REQ_FUA
- dm zoned: reduce overhead of backing device checks
- workqueue: Fix spurious sanity check failures in destroy_workqueue()
- workqueue: Fix pwq ref leak in rescuer_thread()
- ASoC: rt5645: Fixed buddy jack support.
- ASoC: rt5645: Fixed typo for buddy jack support.
- ASoC: Jack: Fix NULL pointer dereference in snd_soc_jack_report
- md: improve handling of bio with REQ_PREFLUSH in md_flush_request()
- blk-mq: avoid sysfs buffer overflow with too many CPU cores
- cgroup: pids: use atomic64_t for pids->limit
- ar5523: check NULL before memcpy() in ar5523_cmd()
- [s390x] mm: properly clear _PAGE_NOEXEC bit when it is not supported
- media: cec.h: CEC_OP_REC_FLAG_ values were swapped
- cpuidle: Do not unset the driver if it is there already
- erofs: zero out when listxattr is called with no xattr
- [x86] intel_th: Fix a double put_device() in error path
- [x86] intel_th: pci: Add Ice Lake CPU support
- [x86] intel_th: pci: Add Tiger Lake CPU support
- PM / devfreq: Lock devfreq in trans_stat_show
- [ppc64el] cpufreq: powernv: fix stack bloat and hard limit on number of
CPUs
- ACPI / hotplug / PCI: Allocate resources directly under the non-hotplug
bridge
- ACPI: OSL: only free map once in osl.c
- ACPI: bus: Fix NULL pointer check in acpi_bus_get_private_data()
- ACPI: PM: Avoid attaching ACPI PM domain to certain devices
- [arm64] pinctrl: armada-37xx: Fix irq mask access in
armada_37xx_irq_set_type()
- [armhf] pinctrl: samsung: Add of_node_put() before return in error path
- [armhf] pinctrl: samsung: Fix device node refcount leaks in Exynos wakeup
controller init
- [armhf] pinctrl: samsung: Fix device node refcount leaks in init code
- [armhf] mmc: host: omap_hsmmc: add code for special init of wl1251 to get
rid of pandora_wl1251_init_card
- [armhf] dts: omap3-tao3530: Fix incorrect MMC card detection GPIO
polarity
- ppdev: fix PPGETTIME/PPSETTIME ioctls
- [ppc64el] Allow 64bit VDSO __kernel_sync_dicache to work across ranges
>4GB
- [ppc64el] xive: Prevent page fault issues in the machine crash handler
- [ppc64el] Allow flush_icache_range to work across ranges >4GB
- [ppc64el] xive: Skip ioremap() of ESB pages for LSI interrupts
- video/hdmi: Fix AVI bar unpack
- quota: Check that quota is not dirty before release
- ext2: check err when partial != NULL
- quota: fix livelock in dquot_writeback_dquots
- ext4: Fix credit estimate for final inode freeing
- reiserfs: fix extended attributes on the root directory
- block: fix single range discard merge
- [s390x] scsi: zfcp: trace channel log even for FCP command responses
- scsi: qla2xxx: Fix DMA unmap leak
- scsi: qla2xxx: Fix hang in fcport delete path
- scsi: qla2xxx: Fix session lookup in qlt_abort_work()
- scsi: qla2xxx: Fix qla24xx_process_bidir_cmd()
- scsi: qla2xxx: Always check the qla2x00_wait_for_hba_online() return value
- scsi: qla2xxx: Fix message indicating vectors used by driver
- scsi: qla2xxx: Fix SRB leak on switch command timeout
- xhci: make sure interrupts are restored to correct state
- usb: typec: fix use after free in typec_register_port()
- [armhf] omap: pdata-quirks: remove openpandora quirks for mmc3 and wl1251
- scsi: lpfc: Cap NPIV vports to 256
- scsi: lpfc: Correct code setting non existent bits in sli4 ABORT WQE
- scsi: lpfc: Correct topology type reporting on G7 adapters
- sch_cake: Correctly update parent qlen when splitting GSO packets
- net/smc: do not wait under send_lock
- [arm64] net: hns3: clear pci private data when unload hns3 driver
- [arm64] net: hns3: change hnae3_register_ae_dev() to int
- [arm64] net: hns3: Check variable is valid before assigning it to another
- [arm64] scsi: hisi_sas: send primitive NOTIFY to SSP situation only
- [arm64] scsi: hisi_sas: Reject setting programmed minimum linkrate > 1.5G
- [x86] MCE/AMD: Turn off MC4_MISC thresholding on all family 0x15 models
- [x86] MCE/AMD: Carve out the MC4_MISC thresholding quirk
- ath10k: fix fw crash by moving chip reset after napi disabled
- [ppc64el] Fix vDSO clock_getres()
- ext4: work around deleting a file with i_nlink == 0 safely
- mm/shmem.c: cast the type of unmap_start to u64
- rtc: disable uie before setting time and enable after
- splice: only read in as much information as there is pipe buffer space
- ext4: fix a bug in ext4_wait_for_tail_page_commit
- [armhf,arm64] mfd: rk808: Fix RK818 ID template
- mm, thp, proc: report THP eligibility for each vma
- [s390x] smp,vdso: fix ASCE handling
- blk-mq: make sure that line break can be printed
- workqueue: Fix missing kfree(rescuer) in destroy_workqueue()
- perf callchain: Fix segfault in thread__resolve_callchain_sample()
- gre: refetch erspan header from skb->data after pskb_may_pull()
- sunrpc: fix crash when cache_head become valid before update
- net/mlx5e: Fix SFF 8472 eeprom length
- leds: trigger: netdev: fix handling on interface rename
- gfs2: fix glock reference problem in gfs2_trans_remove_revoke
- of: overlay: add_changeset_property() memory leak
- kernel/module.c: wakeup processes in module_wq on module unload
- cifs: Fix potential softlockups while refreshing DFS cache
- [x86] gpiolib: acpi: Add Terra Pad 1061 to the
run_edge_events_on_boot_blacklist
- raid5: need to set STRIPE_HANDLE for batch head
- scsi: qla2xxx: Change discovery state before PLOGI
- [x86] iio: imu: mpu6050: add missing available scan masks
- idr: Fix idr_get_next_ul race with idr_remove
- of: unittest: fix memory leak in attach_node_and_children
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.19.91
- inet: protect against too small mtu values.
- mqprio: Fix out-of-bounds access in mqprio_dump
- net: bridge: deny dev_set_mac_address() when unregistering
- net: dsa: fix flow dissection on Tx path
- net: ethernet: ti: cpsw: fix extra rx interrupt
- net: sched: fix dump qlen for sch_mq/sch_mqprio with NOLOCK subqueues
- [arm64] net: thunderx: start phy before starting autonegotiation
- openvswitch: support asymmetric conntrack
- tcp: md5: fix potential overestimation of TCP option space
- tipc: fix ordering of tipc module init and exit routine
- net/mlx5e: Query global pause state before setting prio2buffer
- tcp: fix rejected syncookies due to stale timestamps
- tcp: tighten acceptance of ACKs not matching a child socket
- tcp: Protect accesses to .ts_recent_stamp with {READ,WRITE}_ONCE()
- [arm64] Revert "arm64: preempt: Fix big-endian when checking preempt
count in assembly"
- mmc: block: Make card_busy_detect() a bit more generic
- mmc: block: Add CMD13 polling for MMC IOCTLS with R1B response
- PCI/PM: Always return devices to D0 when thawing
- PCI: pciehp: Avoid returning prematurely from sysfs requests
- [x86] PCI: Fix Intel ACS quirk UPDCR register address
- PCI/MSI: Fix incorrect MSI-X masking on resume
- [arm64] PCI: Apply Cavium ACS quirk to ThunderX2 and ThunderX3
- [arm64] rpmsg: glink: Set tail pointer to 0 at end of FIFO
- [arm64] rpmsg: glink: Fix reuse intents memory leak issue
- [arm64] rpmsg: glink: Fix use after free in open_ack TIMEOUT case
- [arm64] rpmsg: glink: Put an extra reference during cleanup
- [arm64] rpmsg: glink: Fix rpmsg_register_device err handling
- [arm64] rpmsg: glink: Don't send pending rx_done during remove
- [arm64] rpmsg: glink: Free pending deferred work on remove
- cifs: smbd: Return -EAGAIN when transport is reconnecting
- cifs: smbd: Add messages on RDMA session destroy and reconnection
- cifs: smbd: Return -EINVAL when the number of iovs exceeds
SMBDIRECT_MAX_SGE
- cifs: Don't display RDMA transport on reconnect
- CIFS: Respect O_SYNC and O_DIRECT flags during reconnect
- CIFS: Close open handle after interrupted close
- [armhf] tegra: Fix FLOW_CTLR_HALT register clobbering by tegra_resume()
- vfio/pci: call irq_bypass_unregister_producer() before freeing irq
- dma-buf: Fix memory leak in sync_file_merge()
- [arm64] drm: meson: venc: cvbs: fix CVBS mode matching
- dm mpath: remove harmful bio-based optimization
- dm btree: increase rebalance threshold in __rebalance2()
- scsi: iscsi: Fix a potential deadlock in the timeout handler
- scsi: qla2xxx: Change discovery state before PLOGI
- drm/radeon: fix r1xx/r2xx register checker for POT textures
- xhci: fix USB3 device initiated resume race with roothub autosuspend
[ Salvatore Bonaccorso ]
* Refresh powerpc-fix-mcpu-options-for-spe-only-compiler.patch (Context

View File

@ -21,10 +21,8 @@ Signed-off-by: Martin K. Petersen <martin.petersen@oracle.com>
drivers/scsi/hisi_sas/hisi_sas_v3_hw.c | 8 ++-
5 files changed, 70 insertions(+), 40 deletions(-)
Index: linux/drivers/scsi/hisi_sas/hisi_sas.h
===================================================================
--- linux.orig/drivers/scsi/hisi_sas/hisi_sas.h
+++ linux/drivers/scsi/hisi_sas/hisi_sas.h
--- a/drivers/scsi/hisi_sas/hisi_sas.h
+++ b/drivers/scsi/hisi_sas/hisi_sas.h
@@ -34,6 +34,7 @@
#define HISI_SAS_MAX_DEVICES HISI_SAS_MAX_ITCT_ENTRIES
#define HISI_SAS_RESET_BIT 0
@ -41,11 +39,9 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas.h
+ int (*slot_index_alloc)(struct hisi_hba *hisi_hba,
struct domain_device *device);
struct hisi_sas_device *(*alloc_dev)(struct domain_device *device);
void (*sl_notify)(struct hisi_hba *hisi_hba, int phy_no);
Index: linux/drivers/scsi/hisi_sas/hisi_sas_main.c
===================================================================
--- linux.orig/drivers/scsi/hisi_sas/hisi_sas_main.c
+++ linux/drivers/scsi/hisi_sas/hisi_sas_main.c
void (*sl_notify_ssp)(struct hisi_hba *hisi_hba, int phy_no);
--- a/drivers/scsi/hisi_sas/hisi_sas_main.c
+++ b/drivers/scsi/hisi_sas/hisi_sas_main.c
@@ -184,7 +184,14 @@ static void hisi_sas_slot_index_clear(st
static void hisi_sas_slot_index_free(struct hisi_hba *hisi_hba, int slot_idx)
@ -160,7 +156,7 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_main.c
err_out_dma_unmap:
if (!sas_protocol_ata(task->task_proto)) {
if (task->num_scatter) {
@@ -1742,14 +1766,11 @@ hisi_sas_internal_abort_task_exec(struct
@@ -1747,14 +1771,11 @@ hisi_sas_internal_abort_task_exec(struct
port = to_hisi_sas_port(sas_port);
/* simply get a slot and send abort command */
@ -178,7 +174,7 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_main.c
slot = &hisi_hba->slot_info[slot_idx];
spin_lock_irqsave(&dq->lock, flags_dq);
@@ -1785,7 +1806,6 @@ hisi_sas_internal_abort_task_exec(struct
@@ -1790,7 +1811,6 @@ hisi_sas_internal_abort_task_exec(struct
spin_lock_irqsave(&task->task_state_lock, flags);
task->task_state_flags |= SAS_TASK_AT_INITIATOR;
spin_unlock_irqrestore(&task->task_state_lock, flags);
@ -186,7 +182,7 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_main.c
WRITE_ONCE(slot->ready, 1);
/* send abort command to the chip */
spin_lock_irqsave(&dq->lock, flags);
@@ -1796,9 +1816,7 @@ hisi_sas_internal_abort_task_exec(struct
@@ -1801,9 +1821,7 @@ hisi_sas_internal_abort_task_exec(struct
return 0;
err_out_tag:
@ -196,7 +192,7 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_main.c
err_out:
dev_err(dev, "internal abort task prep: failed[%d]!\n", rc);
@@ -2174,6 +2192,8 @@ int hisi_sas_alloc(struct hisi_hba *hisi
@@ -2179,6 +2197,8 @@ int hisi_sas_alloc(struct hisi_hba *hisi
hisi_sas_init_mem(hisi_hba);
hisi_sas_slot_index_init(hisi_hba);
@ -205,7 +201,7 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_main.c
hisi_hba->wq = create_singlethread_workqueue(dev_name(dev));
if (!hisi_hba->wq) {
@@ -2377,8 +2397,15 @@ int hisi_sas_probe(struct platform_devic
@@ -2382,8 +2402,15 @@ int hisi_sas_probe(struct platform_devic
shost->max_channel = 1;
shost->max_cmd_len = 16;
shost->sg_tablesize = min_t(u16, SG_ALL, HISI_SAS_SGE_PAGE_CNT);
@ -223,10 +219,8 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_main.c
sha->sas_ha_name = DRV_NAME;
sha->dev = hisi_hba->dev;
Index: linux/drivers/scsi/hisi_sas/hisi_sas_v1_hw.c
===================================================================
--- linux.orig/drivers/scsi/hisi_sas/hisi_sas_v1_hw.c
+++ linux/drivers/scsi/hisi_sas/hisi_sas_v1_hw.c
--- a/drivers/scsi/hisi_sas/hisi_sas_v1_hw.c
+++ b/drivers/scsi/hisi_sas/hisi_sas_v1_hw.c
@@ -1807,7 +1807,6 @@ static struct scsi_host_template sht_v1_
.scan_start = hisi_sas_scan_start,
.change_queue_depth = sas_change_queue_depth,
@ -235,10 +229,8 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_v1_hw.c
.this_id = -1,
.sg_tablesize = SG_ALL,
.max_sectors = SCSI_DEFAULT_MAX_SECTORS,
Index: linux/drivers/scsi/hisi_sas/hisi_sas_v2_hw.c
===================================================================
--- linux.orig/drivers/scsi/hisi_sas/hisi_sas_v2_hw.c
+++ linux/drivers/scsi/hisi_sas/hisi_sas_v2_hw.c
--- a/drivers/scsi/hisi_sas/hisi_sas_v2_hw.c
+++ b/drivers/scsi/hisi_sas/hisi_sas_v2_hw.c
@@ -770,7 +770,7 @@ static u32 hisi_sas_phy_read32(struct hi
/* This function needs to be protected from pre-emption. */
@ -283,11 +275,9 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_v2_hw.c
.this_id = -1,
.sg_tablesize = SG_ALL,
.max_sectors = SCSI_DEFAULT_MAX_SECTORS,
Index: linux/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
===================================================================
--- linux.orig/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
+++ linux/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
@@ -2096,7 +2096,6 @@ static struct scsi_host_template sht_v3_
--- a/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
+++ b/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
@@ -2108,7 +2108,6 @@ static struct scsi_host_template sht_v3_
.scan_start = hisi_sas_scan_start,
.change_queue_depth = sas_change_queue_depth,
.bios_param = sas_bios_param,
@ -295,7 +285,7 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
.this_id = -1,
.sg_tablesize = SG_ALL,
.max_sectors = SCSI_DEFAULT_MAX_SECTORS,
@@ -2106,6 +2105,7 @@ static struct scsi_host_template sht_v3_
@@ -2118,6 +2117,7 @@ static struct scsi_host_template sht_v3_
.target_destroy = sas_target_destroy,
.ioctl = sas_ioctl,
.shost_attrs = host_attrs,
@ -303,7 +293,7 @@ Index: linux/drivers/scsi/hisi_sas/hisi_sas_v3_hw.c
};
static const struct hisi_sas_hw hisi_sas_v3_hw = {
@@ -2243,8 +2243,10 @@ hisi_sas_v3_probe(struct pci_dev *pdev,
@@ -2255,8 +2255,10 @@ hisi_sas_v3_probe(struct pci_dev *pdev,
shost->max_channel = 1;
shost->max_cmd_len = 16;
shost->sg_tablesize = min_t(u16, SG_ALL, HISI_SAS_SGE_PAGE_CNT);

View File

@ -1,57 +0,0 @@
From: Salvatore Bonaccorso <carnil@debian.org>
Date: Tue, 17 Dec 2019 15:18:10 +0100
Subject: Revert "arm64: preempt: Fix big-endian when checking preempt count in
assembly"
Bug: https://lore.kernel.org/stable/20191214021403.GA1357@home.goodmis.org/
As reported[1] by Steven Rostedt while updating 4.19-rt, the change
breaks without having as well 396244692232f ("arm64: preempt: Provide
our own implementation of asm/preempt.h").
[1]: <https://lore.kernel.org/stable/20191214021403.GA1357@home.goodmis.org/>
Signed-off-by: Salvatore Bonaccorso <carnil@debian.org>
---
arch/arm64/include/asm/assembler.h | 8 +++++---
arch/arm64/kernel/entry.S | 6 ++++--
2 files changed, 9 insertions(+), 5 deletions(-)
diff --git a/arch/arm64/include/asm/assembler.h b/arch/arm64/include/asm/assembler.h
index 0c100506a29a..5a97ac853168 100644
--- a/arch/arm64/include/asm/assembler.h
+++ b/arch/arm64/include/asm/assembler.h
@@ -683,9 +683,11 @@ USER(\label, ic ivau, \tmp2) // invalidate I line PoU
.macro if_will_cond_yield_neon
#ifdef CONFIG_PREEMPT
get_thread_info x0
- ldr x0, [x0, #TSK_TI_PREEMPT]
- sub x0, x0, #PREEMPT_DISABLE_OFFSET
- cbz x0, .Lyield_\@
+ ldr w1, [x0, #TSK_TI_PREEMPT]
+ ldr x0, [x0, #TSK_TI_FLAGS]
+ cmp w1, #PREEMPT_DISABLE_OFFSET
+ csel x0, x0, xzr, eq
+ tbnz x0, #TIF_NEED_RESCHED, .Lyield_\@ // needs rescheduling?
/* fall through to endif_yield_neon */
.subsection 1
.Lyield_\@ :
diff --git a/arch/arm64/kernel/entry.S b/arch/arm64/kernel/entry.S
index bb6832353045..5f800384cb9a 100644
--- a/arch/arm64/kernel/entry.S
+++ b/arch/arm64/kernel/entry.S
@@ -622,8 +622,10 @@ el1_irq:
irq_handler
#ifdef CONFIG_PREEMPT
- ldr x24, [tsk, #TSK_TI_PREEMPT] // get preempt count
- cbnz x24, 1f // preempt count != 0
+ ldr w24, [tsk, #TSK_TI_PREEMPT] // get preempt count
+ cbnz w24, 1f // preempt count != 0
+ ldr x0, [tsk, #TSK_TI_FLAGS] // get flags
+ tbz x0, #TIF_NEED_RESCHED, 1f // needs rescheduling?
bl el1_preempt
1:
#endif
--
2.24.1

View File

@ -101,7 +101,6 @@ bugfix/all/kbuild-include-addtree-remove-quotes-before-matching-path.patch
debian/revert-objtool-fix-config_stack_validation-y-warning.patch
bugfix/all/mt76-use-the-correct-hweight8-function.patch
bugfix/all/rtc-s35390a-set-uie_unsupported.patch
debian/Revert-arm64-preempt-Fix-big-endian-when-checking-pr.patch
# Miscellaneous features