Update to 4.0.6

svn path=/dists/sid/linux/; revision=22778
This commit is contained in:
Ben Hutchings 2015-06-28 22:58:51 +00:00
parent 15d2832b85
commit 029e70eef5
4 changed files with 92 additions and 88 deletions

93
debian/changelog vendored
View File

@ -1,5 +1,96 @@
linux (4.0.5-2) UNRELASED; urgency=medium
linux (4.0.6-1) UNRELEASED; urgency=medium
* New upstream stable update:
https://www.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.0.6
- crush: ensuring at most num-rep osds are selected
- aio: fix serial draining in exit_aio()
- net: core: Correct an over-stringent device loop detection.
- [x86] bpf_jit: fix FROM_BE16 and FROM_LE16/32 instructions
- [x86] bpf_jit: fix compilation of large bpf programs
- net: phy: Allow EEE for all RGMII variants
- netlink: Reset portid after netlink_insert failure
- rtnl/bond: don't send rtnl msg for unregistered iface
- tcp/ipv6: fix flow label setting in TIME_WAIT state
- net/ipv6/udp: Fix ipv6 multicast socket filter regression
- net: sched: fix call_rcu() race on classifier module unloads
- ipv4: Avoid crashing in ip_error
- cdc_ncm: Fix tx_bytes statistics
- bridge: fix parsing of MLDv2 reports
- net: dp83640: fix broken calibration routine.
- net: dp83640: reinforce locking rules.
- net: dp83640: fix improper double spin locking.
- unix/caif: sk_socket can disappear when state is unlocked
- xen/netback: Properly initialize credit_bytes
- net_sched: invoke ->attach() after setting dev->qdisc
- sctp: Fix mangled IPv4 addresses on a IPv6 listening socket
- bridge: fix br_multicast_query_expired() bug
- udp: fix behavior of wrong checksums
- tcp: fix child sockets to use system default congestion control if not set
- xen: netback: read hotplug script once at start of day.
- ipv4/udp: Verify multicast group is ours in upd_v4_early_demux()
- be2net: Replace dma/pci_alloc_coherent() calls with dma_zalloc_coherent()
- bridge: disable softirqs around br_fdb_update to avoid lockup
- netlink: Disable insertions/removals during rehash
- drivers/base: cacheinfo: handle absence of caches
- n_tty: Fix auditing support for cannonical mode
- [x86] iommu/vt-d: Allow RMRR on graphics devices too
- [x86] iommu/vt-d: Fix passthrough mode with translation-disabled devices
- ALSA: hda/realtek - Add a fixup for another Acer Aspire 9420
- ALSA: usb-audio: Add mic volume fix quirk for Logitech Quickcam Fusion
- ALSA: usb-audio: don't try to get Outlaw RR2150 sample rate
- ALSA: usb-audio: add MAYA44 USB+ mixer control names
- ALSA: usb-audio: fix missing input volume controls in MAYA44 USB(+)
- ALSA: usb-audio: add native DSD support for JLsounds I2SoverUSB
- [armhf] dmaengine: pl330: Fix hang on dmaengine_terminate_all on certain
boards
- dmaengine: Fix choppy sound because of unimplemented resume
- Input: alps - do not reduce trackpoint speed by half
- Input: synaptics - add min/max quirk for Lenovo S540
- Input: elantech - fix detection of touchpads where the revision matches
a known rate
- Input: elantech - add new icbody type
- block: fix ext_dev_lock lockdep report
- block: discard bdi_unregister() in favour of bdi_destroy()
- USB: cp210x: add ID for HubZ dual ZigBee and Z-Wave dongle
- USB: serial: ftdi_sio: Add support for a Motion Tracker Development Board
- usb: host: xhci: add mutex for non-thread-safe data
- usb: make module xhci_hcd removable
- [x86] asm/irq: Stop relying on magic JMP behavior for early_idt_handlers
- [armhf] dts: am335x-boneblack: disable RTC-only sleep to avoid hardware
damage
- [x86] drm/amdkfd: fix topology bug with capability attr.
- drm/radeon: use proper ACR regisiter for DCE3.2
- [x86] drm/i915/hsw: Fix workaround for server AUX channel clock divisor
- [x86] drm/i915: Don't skip request retirement if the active list is empty
- [x86] drm/i915: Fix DDC probe for passive adapters
- drm/radeon: fix freeze for laptop with Turks/Thames GPU.
- Revert "drm/radeon: don't share plls if monitors differ in audio support"
- Revert "drm/radeon: adjust pll when audio is not enabled"
- drm/radeon: Make sure radeon_vm_bo_set_addr always unreserves the BO
- serial: imx: Fix DMA handling for IDLE condition aborts
- [powerpc*] of/dynamic: Fix test for PPC_PSERIES
- virtio_pci: Clear stale cpumask when setting irq affinity
- [armel,armhf] bus: mvebu-mbus: do not set WIN_CTRL_SYNCBARRIER on non
io-coherent platforms.
- [armel,armhf] Revert "bus: mvebu-mbus: make sure SDRAM CS for DMA don't
overlap the MBus bridge window"
- [arm64] dts: mt8173-evb: fix model name
- mm/memory_hotplug.c: set zone->wait_table to null after freeing it
- md: Close race when setting 'action' to 'idle'.
- md: don't return 0 from array_state_store
- sched, numa: do not hint for NUMA balancing on VM_MIXEDMAP mappings
- blk-mq: free hctx->ctxs in queue's release handler
- cfg80211: wext: clear sinfo struct before calling driver
- [armhf] irqchip: sunxi-nmi: Fix off-by-one error in irq iterator
- Btrfs: send, add missing check for dead clone root
- Btrfs: send, don't leave without decrementing clone root's send_progress
- btrfs: incorrect handling for fiemap_fill_next_extent return
- btrfs: cleanup orphans while looking up default subvolume
- Btrfs: fix range cloning when same inode used as source and destination
- Btrfs: fix uninit variable in clone ioctl
- Btrfs: fix regression in raid level conversion
[ Ben Hutchings ]
* mm: Re-enable ZBUD as module (Closes: #789094)
* mm: Change ZSMALLOC from built-in to module

View File

@ -1,35 +0,0 @@
From: =?UTF-8?q?Bj=C3=B8rn=20Mork?= <bjorn@mork.no>
Date: Fri, 22 May 2015 13:15:22 +0200
Subject: cdc_ncm: Fix tx_bytes statistics
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Origin: https://git.kernel.org/linus/44f6731d8b68fa02f5ed65eaceac41f8c3c9279e
The tx_curr_frame_payload field is u32. When we try to calculate a
small negative delta based on it, we end up with a positive integer
close to 2^32 instead. So the tx_bytes pointer increases by about
2^32 for every transmitted frame.
Fix by calculating the delta as a signed long.
Cc: Ben Hutchings <ben.hutchings@codethink.co.uk>
Reported-by: Florian Bruhin <me@the-compiler.org>
Fixes: 7a1e890e2168 ("usbnet: Fix tx_bytes statistic running backward in cdc_ncm")
Signed-off-by: Bjørn Mork <bjorn@mork.no>
Signed-off-by: David S. Miller <davem@davemloft.net>
---
drivers/net/usb/cdc_ncm.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
--- a/drivers/net/usb/cdc_ncm.c
+++ b/drivers/net/usb/cdc_ncm.c
@@ -1178,7 +1178,7 @@ cdc_ncm_fill_tx_frame(struct usbnet *dev
* payload data instead.
*/
usbnet_set_skb_tx_stats(skb_out, n,
- ctx->tx_curr_frame_payload - skb_out->len);
+ (long)ctx->tx_curr_frame_payload - skb_out->len);
return skb_out;

View File

@ -1,50 +0,0 @@
From f16b8208c320e4f8433a03acb7756d90f1b57981 Mon Sep 17 00:00:00 2001
From: Nicolas Schichan <nschichan@freebox.fr>
Date: Thu, 28 May 2015 10:40:12 +0200
Subject: [PATCH] bus: mvebu-mbus: do not set WIN_CTRL_SYNCBARRIER on non
io-coherent platforms.
Origin: http://article.gmane.org/gmane.linux.kernel.stable/137371
Commit a0b5cd4ac2d6 ("bus: mvebu-mbus: use automatic I/O
synchronization barriers") enabled the usage of automatic I/O
synchronization barriers by enabling bit WIN_CTRL_SYNCBARRIER in the
control registers of MBus windows, but on non io-coherent platforms
(orion5x, kirkwood and dove) the WIN_CTRL_SYNCBARRIER bit in
the window control register is either reserved (all windows except 6
and 7) or enables read-only protection (windows 6 and 7).
Signed-off-by: Nicolas Schichan <nschichan@freebox.fr>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: <stable@vger.kernel.org> # v4.0+
Fixes: a0b5cd4ac2d6 ("bus: mvebu-mbus: use automatic I/O synchronization barriers")
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
drivers/bus/mvebu-mbus.c | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/drivers/bus/mvebu-mbus.c b/drivers/bus/mvebu-mbus.c
index fb9ec62..7fa4510 100644
--- a/drivers/bus/mvebu-mbus.c
+++ b/drivers/bus/mvebu-mbus.c
@@ -70,6 +70,7 @@
*/
#define WIN_CTRL_OFF 0x0000
#define WIN_CTRL_ENABLE BIT(0)
+/* Only on HW I/O coherency capable platforms */
#define WIN_CTRL_SYNCBARRIER BIT(1)
#define WIN_CTRL_TGT_MASK 0xf0
#define WIN_CTRL_TGT_SHIFT 4
@@ -323,8 +324,9 @@ static int mvebu_mbus_setup_window(struct mvebu_mbus_state *mbus,
ctrl = ((size - 1) & WIN_CTRL_SIZE_MASK) |
(attr << WIN_CTRL_ATTR_SHIFT) |
(target << WIN_CTRL_TGT_SHIFT) |
- WIN_CTRL_SYNCBARRIER |
WIN_CTRL_ENABLE;
+ if (mbus->hw_io_coherency)
+ ctrl |= WIN_CTRL_SYNCBARRIER;
writel(base & WIN_BASE_LOW, addr + WIN_BASE_OFF);
writel(ctrl, addr + WIN_CTRL_OFF);
--
2.1.4

View File

@ -42,7 +42,6 @@ bugfix/mips/disable-advansys.patch
bugfix/arm64/arm64-add-missing-dts-entry-for-X-Gene-platform.patch
bugfix/arm64/arm64-removed-using-of-the-mask-attribute-in-the-dts.patch
bugfix/x86/config-enable-need_dma_map_state-by-default-when-swi.patch
bugfix/armel/bus-mvebu-mbus-do-not-set-WIN_CTRL_SYNCBARRIER-on-no.patch
# Arch features
features/mips/MIPS-increase-MAX-PHYSMEM-BITS-on-Loongson-3-only.patch
@ -65,7 +64,6 @@ bugfix/all/ext4-allocate-entire-range-in-zero-range.patch
debian/emmc-don-t-initialize-partitions-on-rpmb-flagged-areas.patch
bugfix/all/rtc-hctosys-do-not-treat-lack-of-rtc-device-as-error.patch
bugfix/all/rtc-hctosys-use-function-name-in-the-error-log.patch
bugfix/all/cdc_ncm-fix-tx_bytes-statistics.patch
bugfix/all/musb-musb-fix-order-of-conditions-for-assigning-end-p.patch
# Miscellaneous features