[powerpc] Fix build error in stable/3.9

svn path=/dists/sid/linux/; revision=20221
This commit is contained in:
Ben Hutchings 2013-06-09 21:51:41 +00:00
parent 2b5499bb75
commit 01f7477a15
3 changed files with 37 additions and 0 deletions

1
debian/changelog vendored
View File

@ -49,6 +49,7 @@ linux (3.9.5-1) UNRELEASED; urgency=low
* [powerpcspe] Remove installer udebs (really fixes FTBFS)
* [s390] Add pgste to ptep_modify_prot_start()
* [s390] Enable PCI, PCI and USB drivers
* [powerpc] Fix build error in stable/3.9
-- Ben Hutchings <ben@decadent.org.uk> Sat, 08 Jun 2013 15:25:11 +0100

View File

@ -0,0 +1,35 @@
From: Guenter Roeck <linux@roeck-us.net>
Date: Sat, 8 Jun 2013 07:23:47 -0700
Subject: powerpc: Fix build error in stable/3.9
Commit e71c42189 (powerpc/tm: Abort on emulation and alignment faults)
introduced a powerpc build error in 3.9.5.
Signed-off-by: Guenter Roeck <linux@roeck-us.net>
---
No upstream commit. Compile tested only.
arch/powerpc/kernel/traps.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/arch/powerpc/kernel/traps.c b/arch/powerpc/kernel/traps.c
index 1c22b2d..29857c6 100644
--- a/arch/powerpc/kernel/traps.c
+++ b/arch/powerpc/kernel/traps.c
@@ -1151,7 +1151,7 @@ void alignment_exception(struct pt_regs *regs)
local_irq_enable();
if (tm_abort_check(regs, TM_CAUSE_ALIGNMENT | TM_CAUSE_PERSISTENT))
- goto bail;
+ return;
/* we don't implement logging of alignment exceptions */
if (!(current->thread.align_ctl & PR_UNALIGN_SIGBUS))
--
1.7.9.7
--
To unsubscribe from this list: send the line "unsubscribe stable" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html

View File

@ -105,3 +105,4 @@ features/arm/0001-thermal-Add-driver-for-Armada-370-XP-SoC-thermal-man.patch
features/arm/0001-ARM-mvebu-Add-thermal-support-to-Armada-XP-device-tr.patch
bugfix/s390/s390-add-pgste-to-ptep_modify_prot_start.patch
bugfix/powerpc/powerpc-fix-build-error-in-stable-3.9.patch