* [mips] Fix SWARM FPU detection.

svn path=/dists/trunk/linux-2.6/; revision=6740
This commit is contained in:
Thiemo Seufer 2006-05-29 01:14:01 +00:00
parent fb134ff905
commit 01edb0e569
3 changed files with 15 additions and 0 deletions

3
debian/changelog vendored
View File

@ -6,6 +6,9 @@ linux-2.6 (2.6.16+2.6.17-rc5-0experimental.1) UNRELEASED; urgency=low
[ Martin Michlmayr ]
* [mips] Update patches for 2.6.17.
[ Thiemo Seufer ]
* [mips] Fix SWARM FPU detection.
[ Kyle McMartin ]
* [hppa] Disable CONFIG_DETECT_SOFTLOCKUP to fix pa8800 boot.

11
debian/patches/mips-sb1-pass1fpu.patch vendored Normal file
View File

@ -0,0 +1,11 @@
--- linux-orig/arch/mips/kernel/cpu-probe.c 2006-05-15 02:07:55.000000000 +0100
+++ linux-work-stable/arch/mips/kernel/cpu-probe.c 2006-05-28 23:59:12.000000000 +0100
@@ -652,7 +648,7 @@ static inline void cpu_probe_sibyte(stru
case PRID_IMP_SB1:
c->cputype = CPU_SB1;
/* FPU in pass1 is known to have issues. */
- if ((c->processor_id & 0xff) < 0x20)
+ if ((c->processor_id & 0xff) < 0x02)
c->options &= ~(MIPS_CPU_FPU | MIPS_CPU_32FPR);
break;
case PRID_IMP_SB1A:

View File

@ -23,3 +23,4 @@
+ mips-sb1-duart-tts.patch
+ s390-arch-kernel-time.patch
#FIXME + powerpc-mkvmlinuz-support-2.patch
+ mips-sb1-pass1fpu.patch