[ppc64el] Avoid ABI change for disabling TM

Ignore removal of TM functions that are exported for use by KVM.
This commit is contained in:
Ben Hutchings 2019-08-22 19:28:48 +01:00
parent 019113b013
commit 00ee7f7173
4 changed files with 40 additions and 0 deletions

1
debian/changelog vendored
View File

@ -7,6 +7,7 @@ linux (4.19.67-2) UNRELEASED; urgency=medium
[ Ben Hutchings ]
* KVM: Ignore ABI changes
* [ppc64el] Disable PPC_TRANSACTIONAL_MEM (Closes: #866122)
* [ppc64el] Avoid ABI change for disabling TM
-- Ben Hutchings <ben@decadent.org.uk> Wed, 21 Aug 2019 23:37:56 +0100

View File

@ -88,6 +88,10 @@ ignore-changes:
mark_page_dirty
vcpu_*
module:arch/x86/kvm/*
# Only exported for use by KVM
tm_abort
tm_disable
tm_enable
[base]
arches:

View File

@ -0,0 +1,34 @@
From: Ben Hutchings <ben@decadent.org.uk>
Date: Thu, 22 Aug 2019 19:26:31 +0100
Subject: powerpc: Avoid ABI change for disabling TM
Forwarded: not-needed
Keep the TM state in struct paca_struct and struct thread_struct even
though we won't be using it any more.
The KVM state structures will change, but we ignore ABI changes there
since they won't affect out-of-tree modules.
---
--- a/arch/powerpc/include/asm/paca.h
+++ b/arch/powerpc/include/asm/paca.h
@@ -173,7 +173,7 @@ struct paca_struct {
u8 pmcregs_in_use; /* pseries puts this in lppaca */
#endif
u64 sprg_vdso; /* Saved user-visible sprg */
-#ifdef CONFIG_PPC_TRANSACTIONAL_MEM
+#if 1 /* ifdef CONFIG_PPC_TRANSACTIONAL_MEM */
u64 tm_scratch; /* TM scratch area for reclaim */
#endif
--- a/arch/powerpc/include/asm/processor.h
+++ b/arch/powerpc/include/asm/processor.h
@@ -293,7 +293,7 @@ struct thread_struct {
call or trap return */
int used_spe; /* set if process has used spe */
#endif /* CONFIG_SPE */
-#ifdef CONFIG_PPC_TRANSACTIONAL_MEM
+#if 1 /* ifdef CONFIG_PPC_TRANSACTIONAL_MEM */
u8 load_tm;
u64 tm_tfhar; /* Transaction fail handler addr */
u64 tm_texasr; /* Transaction exception & summary */

View File

@ -248,3 +248,4 @@ bugfix/arm64/huawei-taishan/0032-scsi-hisi_sas-Fix-NULL-pointer-dereference.patc
bugfix/arm64/huawei-taishan/0033-scsi-hisi_sas-fix-calls-to-dma_set_mask_and_coherent.patch
# ABI maintenance
debian/abi/powerpc-avoid-abi-change-for-disabling-tm.patch