Don't include non-installed files (fix_install_paths.patch)

* Include bash-completion file:
  * Add fix_install_paths.patch to install it to the correct location.
* Add dracut file to the package.
* Remove (unpackaged) example configuration files in /etc/dahdi.
* Remove (unpackaged and duplicate) /etc/ udev rules.
* Remove an unused .la file.
This commit is contained in:
Tzafrir Cohen 2020-08-19 23:58:33 +03:00
parent 2522272bb0
commit 5cf4228733
4 changed files with 22 additions and 0 deletions

View File

@ -2,3 +2,5 @@ usr/sbin/*
usr/share/perl5/Dahdi*
usr/share/dahdi/*
usr/share/man/man8/*
usr/lib/dracut/dracut.conf.d/50-dahdi.conf
usr/share/bash-completion/completions/dahdi

16
debian/patches/fix_install_paths.patch vendored Normal file
View File

@ -0,0 +1,16 @@
From: Tzafrir Cohen <tzafrir@debian.org>
Subject: Change defaults for some install paths
Index: dahdi-tools/Makefile.am
===================================================================
--- dahdi-tools.orig/Makefile.am 2020-08-19 23:41:45.003051626 +0300
+++ dahdi-tools/Makefile.am 2020-08-19 23:41:44.999051671 +0300
@@ -111,7 +111,7 @@
@echo "Compatibility symlinks (should be removed in the future)"
ln -sf libtonezone.so.2.0.0 $(DESTDIR)$(libdir)/libtonezone.so.2.0
-bashcompdir = $(sysconfdir)/bash_completion.d
+bashcompdir = $(datadir)/bash-completion/completions
install-data-hook:
mkdir -p $(DESTDIR)$(bashcompdir)

View File

@ -5,3 +5,4 @@ soname.patch
dahdi_spantypes.patch
typos.patch
dahdi-tools-3.1.0-fno-common.patch
fix_install_paths.patch

3
debian/rules vendored
View File

@ -53,3 +53,6 @@ override_dh_auto_install:
# also run the 'config' target, in addition to the 'install' target:
dh_auto_install -- config
rm $(CURDIR)/debian/tmp/usr/share/dahdi/span_config.d/50-asterisk
rm $(CURDIR)/debian/tmp/usr/lib/*/libtonezone.la
rm -rf $(CURDIR)/debian/tmp/etc/dahdi
rm -rf $(CURDIR)/debian/tmp/etc/udev/rules.d